Try this next time to confirm what adapter is actually plugged in to a switch:
This will not only tell you where you have a connection but it will also tell you what speed the port on the switch is.
# netstat -v grep -E "ETHERMedia"
ETHERNET STATISTICS (ent0) :
Media Speed Selected: 100 Mbps Full Duplex
Media Speed Running: 100 Mbps Full Duplex
ETHERNET STATISTICS (ent1) :
Media Speed Selected: 1000 Mbps Full Duplex
Media Speed Running: 1000 Mbps Full Duplex
----------------------------------------------------------------------------------------------------------------
2. How to determine if IBM AIX 64 bit kernel (sotware) is installed on your IBM AIX server?
# lslpp -l bos.64bit
bos.64bit 4.3.3.76 COMMITTED Base Operating System 64 bit
----------------------------------------------------------------------------------------------------------------
3. How you create a snapshot of your IBM AIX server to send to IBM for tech support ?
This is requried whenver you face issues with your server and you seek help from IBM to sort out the issue.
# snap -gc
This will create a file called snap.pax.Z in the directory /tmp/ibmsupt. Send this file to IBM so that they will get full configuration of your server.
----------------------------------------------------------------------------------------------------------------
4. How to enable entended history in AIX 5.3 ?
In AIX 5.3, you have the capability to have a time stamped history. To enable it, just set the following variable:
EXTENDED_HISTORY=ON
Example:
export EXTENDED_HISTORY=ON
If required add this line to your .profile.
----------------------------------------------------------------------------------------------------------------
5. How to find the microcode level of tape drives ?
To find microcode level (firmware) of tape drives in IBM AIX:
# tapeutil -f /dev/rmt1 vpd
----------------------------------------------------------------------------------------------------------------
6. pgrep and pkill - how to terminate processes ?
You can use the pgrep and pkill commands to identify and stop command processes that you no longer want to run. These commands are useful when you mistakenly start a process that takes a long time to run.
To terminate a process:
a. pgrep - to find out the PID(s) for the process(es)
b. pkill - followed by the PID(s)
The following example illustrates how to find all the processes with a specific name (xterm) and terminate the xterm process that was started last.
# pgrep xterm 17818 17828 17758 18210
# pkill -n 18210
Note: If you need to forcibly terminate a process, use the -9 option to the pkill command.
For Example
# kill -9 -n xterm
----------------------------------------------------------------------------------------------------------------
7. How to modify Asynchronous I/O variables in AIX ?
To modify the minservers asynchronous I/O variable (MINIMUM number of servers) in IBM AIX:
# chdev -l aio0 -a minservers='1'
To modify the maxservers asynchronous I/O variable (MAXIMUM number of servers per cpu) in IBM AIX 5L:
# chdev -l aio0 -a maxservers='10'
To modify the maxservers asynchronous I/O variable (MAXIMUM number of servers) in IBM AIX v4.3:
# chdev -l aio0 -a maxservers='80'
To modify the requests asynchronous I/O variable (Maximum number of REQUESTS) in IBM AIX:
# chdev -l aio0 -a requests='4096'
Notes:
1) Valeus will only take effect after a reboot
2) You may use multiple -a options on the same command line3)
The maxservers variable is PER CPU for AIX 5L and TOTAL for AIX v4.3
----------------------------------------------------------------------------------------------------------------
8. How to display microcode and firmware levels of the system and adapters in IBM AIX ?
To displays microcode level information for all supported devices in IBM AIX :
# lsmcode -A
sys0!system:SF240_284 (t) SF240_261 (p) SF240_284 (t)
ent0!14108902.DV0210
ent1!14108902.DV0210
ent2!14108902.DV0210
ent3!14108902.DV0210
sisscsia0!44415254.05080064
sisscsia1!44415255.050A0064
hdisk0!ST37320.4A553042.43373038
hdisk1!ST37320.4A553042.43373038
----------------------------------------------------------------------------------------------------------------
9. How to determine if simultaneous multi-threading (SMT) is enabled in AIX ?
Your system is capable of SMT if it's a POWER5-based system running AIX 5L Version 5.3.To determine if it is enabled:# smtctl
To enable SMT: # smtctl -m on [ -w boot now]
To disable SMT: # smtctl -m off [ -w boot now]
Note: If neither the -w boot or the -w now options are specified, then the mode change is made immediately. It persists across subsequent reboots if you run the bosboot command before the next system reboot.
----------------------------------------------------------------------------------------------------------------
10. How to find top users of memory space in IBM AIX ?
To list the top ten users of paging space in IBM AIX:
# svmon -Pgt 10
To list the top ten users of realmem in IBM AIX:
# svmon -Put 10
----------------------------------------------------------------------------------------------------------------
Thursday, January 15, 2009
AIX - Tips & Tricks
1. To confirm which network adapter is plugged into the switch in IBM AIX
Subscribe to:
Post Comments (Atom)
1 comment:
Do you actually have pgrep/pkill installed on AIX? I haven't been able to get a version to compile there. Can you share the source code?
-Ross
Post a Comment